500 Error on my Environment

I installed DomainMod using this Docker container a few weeks back, and it was working fine and then 500 error for last few days. I know 500 error are vague and can mean a ton of things, but when I go to find the error log in that environment I am not finding anything to go off. I am sure it is some kind of PHP error, but I have no clue where to track down the error log. It was install in /home/domainmod/docker/, but I am noticing the containers are in /var/lib/docker/

So, I was hoping for a hint on where I might run down the error log to see what is behind the 500 error, the logs tab in Jelastic for this container is empty, btw, just in case you though I didn’t look, which is a healthy assumption :slight_smile:

You can check logs within a docker container by running

docker logs imagename

where imagename is the name of the docker container. To confirm the container name you can run

docker ps

In your case the container is named software so docker logs software outputs the full log and I see the error

[Mon Oct 05 20:21:19.658595 2020] [php7:error] [pid 17] [client 209.126.3.185:48470] PHP Fatal error:  Uncaught PDOException: SQLSTATE[HY000] [1045] Access denied for user 'doma
inmod'@'172.18.0.3' (using password: YES) in /var/www/html/classes/DomainMOD/Database.php:33\nStack trace:\n#0 /var/www/html/classes/DomainMOD/Database.php(33): PDO->__construct
('mysql:host=data...', 'domainmod', 'password', Array)\n#1 /var/www/html/classes/DomainMOD/Database.php(46): DomainMOD\\Database->__construct()\n#2 /var/www/html/index.php(29): 
DomainMOD\\Database::getInstance()\n#3 {main}\n  thrown in /var/www/html/classes/DomainMOD/Database.php on line 33

So it looks like the database information is incorrect. In particular that the database user credentials are not correct. Beyond that not sure how the software is configured in terms of a database but that’s at least the source of the 500 error which should help.

1 Like