Installatron Customization--WP Plugins


#1

I’m updating the default package for our new WordPress installs in Installatron, and wanted all the plugins to install to the current version. I edited the script for several plugins (e.g., Really Simple SSL, WordPress Importer) that had been installing less than current versions. So, for example, I updated Really Simple SSL to:

$o->registerArchive(“really_simple_ssl”,“http://downloads.wordpress.org/plugin/really-simple-ssl.3.1.4.zip”, “zip”);

However, Installatron is still installing the older version (3.1.3). Same with several other plugins. Is there something I’m overlooking? Also, would like to install the latest version of themes, but I don’t see a way to ensure that the latest versions install by default.

More broadly, I’d be interested in knowing what plugs folks are putting into their default installs. Ours include Classic Editor, Hypothesis, Cookies for Comments, WordPress Importer, Head, Footer and Post Injections, Subscribe to Comments, and Import Users from CSV with meta.

Thanks,

Mo


#2

I strongly recommend the use of Templates which don’t require any code Using Templates in Installatron – Domain of One’s Own. They allow you to create a templated install in any account and then turn it into a template that is used for new installs. Much easier to keep up to date and no monkeying with PHP code.


#3

Thanks Tim, that makes a lot of sense.


#4

Thank you, very good answer for me too.