Issues with Scalar and PHP versions

Hi there,
I am trying to build in Scalar and keep encountering PHP errors that make it impossible to do so (“Array and string offset access syntax with curly braces is deprecated” and “Cannot modify header information”).

I’ve learned from other forums that Scalar has issues with more recent versions of PHP. Is this the case and should I change the PHP version in cPanel? Worried that doing so might affect my other applications (Omeka, WordPress)…

Or, is there a way I can get around those messages?
Thanks for any guidance!

I don’t think Scalar is supporting PHP 7.4 yet. You can switch it to 7.2 following this guide Changing your PHP version

Thanks! Will the change affect the use of other applications, like Omeka and WP?

As far as I’m aware Omeka and WordPress work with the latest version of PHP but cPanel also lets you set this on a per-subdomain basis if you need to run one application on a different version.

Updating this topic here to let folks know the latest version of Scalar released last week includes support for PHP 7.4. Any install on Reclaim through Installatron would have received an automatic update.

1 Like