MediaWiki via Installatron is asking for the fileinfo PHP module


#1

I’ve been trying to help a colleague install and configure the Scripto plugin for Omeka, which requires a MediaWiki installation, among other things. When I’ve installed MediaWiki, it is complaining about not seeing the PHP fileinfo module. When I check the results of phpinfo(); I see fileinfo listed as an installed module, though.

I have confirmed that an independent install of MediaWiki (not within a subdirectory of the /omeka/ ) is also throwing the same error.

Any ideas?


#2

Installatron recently did an overhaul of their “requirements” stuff and I wonder if they’re misreading this somehow (surprising they haven’t caught it). We’ll look into it and see if there’s a way to force it but I may need to reach out to them for a fix.


#3

So a test in my account worked. Private message me what account and URL you’re installing to and I’d be happy to troubleshoot this.


#4

Turns out your server actually didn’t have the fileinfo PHP extension after all (I think the reference in phpinfo was to something else but not the full extension). Once I got that installed the wiki instance worked perfectly. Sorry about that!