MySQL hostname for Omeka S?


#1

I’m trying to install Omeka-S using these instructions under “Installing from released zip file”:

I created a user and databse using the MySQL database wizard tool in cpanel, and I’ve found the config/database.ini file to edit. I just don’t know what the host name should be. Is it supposed to be localhost?

At any rate, it’s not working, and this is my first stop for troubleshooting.


#2

It would indeed be localhost for our servers. Additionally you’ll want to make sure your database username and database name include the prefix, typically your cPanel user (so if your cPanel username is towens usually a database name will take the format towens_omekas)

If that’s not working let us know what error you’re getting and we can probably be of more help.


#3

Thanks and sorry to delay my reply. I had all the settings right, I just needed to have quotation marks around them. For other people reading this, that meant it needed to look like this, with the first 3 of course being things I set using the MySQL Database Wizard.

user = "user_name"
password = "aPassword"
dbname = "a_database"
host = “localhost”
;port =
;unix_socket =
;log_path =