PHP 7.4 as Default

As announced earlier this year, Reclaim Hosting will be making the default version of PHP on all servers 7.4. This follows best practices and guidance on the supported versions of PHP that are still receiving updates. We will decommission all versions of PHP lower than 7.2 but users will have the option to run any version from 7.2 upwards. For software that is not compatible with at least PHP 7.2 you will need to find alternative hosting arrangements.

You can read about how to change the version of PHP your website runs at Changing your PHP version and it’s very easy to switch between versions to test compatibility.

Troubleshooting

If your site is currently broken it could be due to having an older version of PHP that has now been decommissioned. To check this you will want to go follow the guide Changing your PHP version and test the website on PHP 7.2 or higher.

In some cases while the software you are running be it WordPress, Omeka, or something else might be compatible with your version of PHP, the plugins running on there may be out of date or not compatible. It’s important to check not just core software but also plugin and theme compatibility to ensure your website works as expected. As a reminder troubleshooting application code and compatibility is beyond the scope of Reclaim Hosting’s support. Please be sure to utilize the support options for the software that you run for assistance in this regard.

When you say

We will decommission all versions of PHP lower than 7.2

does that mean sites running the older versions will break? I’m trying to help some folks with sites that have an older version (from the dashboard warning) but I do not have access to their cpanel.

Yes the older versions will be completely removed from our servers so if an account is forcing a lower version number the site will be broken until they update to a more recent version (turns out our wizard @cblankenship was able to script updating older versions so sites will only break if they have compability issues). Users that have the “inherit” setting will automatically be upgraded to PHP 7.4 (and were running 7.2 prior to this change).

Worth noting WordPress considers PHP 7.2 an older version, so if they are on 7.2 (which is the default so likely for most) their site would not break unless there are components that are not compatible with PHP 7.4. But they can always lower to 7.2 again, just not lower.

All is good. I sent the link for the instructions on how to do it, and we are set to 7.4 now.

Next I need to sit and fix some really old mysql connect scripts on http://5card.cogdogblog.com that only worked in 5.4

Web sites are never done!

1 Like