I’d like to play with a Laravel app, which requires PHP 7.1+. I followed this article’s instructions and bumped the version on the subdomain to 7.2.
[me@server photos.ohheybrian.com]$ php -v PHP 7.2.17 (cli) (built: Apr 9 2019 04:39:36) ( NTS )
When I SSH into the directory and run the
composer script, I get an error that my PHP version is too low:
Problem 1 - This package requires php ^7.1.3 but your PHP version (7.0.33) does not satisfy that requirement. Problem 2 - Installation request for doctrine/cache v1.8.0 -> satisfiable by doctrine/cache[v1.8.0]. - doctrine/cache v1.8.0 requires php ~7.1 -> your PHP version (7.0.33) does not satisfy that requirement. ...
So, it looks like my CLI version was updated, but not the runtime. Is there another spot to change that version?