Privacy Error/SSL Certificate Issue


#1

When I went to log into my WordPress backend, I got this error:
privacyerror

So I did some quick searching on the site here. Suspecting it was a certificate invalidation issue (as stated in the error message), I went to my CPanel and reissued the SSL certificate using Tim’s instructions. This solved the problem.

However, I was rather surprised that it didn’t automatically reissue. Am I incorrect in thinking that it should auto-certify? Or is the expiration date something that I need to keep track of on my own?

Thanks!


#2

The problem we’re seeing is that the plugin we use for Let’s Encrypt integration will not replace certificates that already exist. In this case the certificate was issued by cPanel. We’re looking into whether we should ditch Let’s Encrypt and have cPanel issue all certs (cPanle didn’t offer their own certs back when we added Let’s Encrypt as an option). Hoping to get this resolved soon so that all certs reliably renew themselves since that’s the ideal.


#3

Thanks for the info!