Trying to convert my WP to multisite. Failing


#1

Hi. I’m trying to change my recently-begun install of WP to multisite so that I can have my academic, personal, and project blogs all in one location. However, despite following directions-- and looking at directions in multiple places-- whenever I try to add a new subdomain/site, it seems to not actually work. An example: I created a new subdomain for my academic blog, which should live here:

But despite showing up as one of my sites in the dashboard, it just gives a directory page. trying to go to the wp-admin page for that subdomain produces the following error message:
Not Found
The requested URL /wp-admin/ was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

I’m frustrated and feeling out of my depth, and I’m sure it’s something obvious. Should I just back up my blog, get rid of my installation of WP, and use Installotron to create a new multisite WP install?


#2

When doing a wildcard subdomain for multisite you want the wildcard subdomain to point to the same directory on the server that your WordPress install is hosted from, in this case public_html. So instead of this:

It becomes this:

The other piece that was missing here is that the .htaccess file had not been changed to the multisite version under Network Admin > Settings > Network Setup. I just added that. Have a look, all should be working now!


#3

I cannot thank you enough. Wasted HOURS trying to figure out what I did wrong, and I’m racing the clock on this-- my old domain expires in like two days. THANK YOU!!!


#4

Don’t ever hesitate to reach out! Glad to help :slight_smile: