Ugh, Email Not Connecting


#1

I know email’s not entirely your jam, and yet. We’ve got a situation with a family member using email through my domain who can only receive mail when logging in insecurely. (Not using SSL and explicitly checking the box that says “Allow insecure connection”.)

Client is Apple Mail, and I’ve tried walking through the client config steps at https://triptronix.net:2096/cpsess2140317596/webmail/paper_lantern/mail/clientconf.html with no success. Used to work 10 days ago, though!

I know you can’t debug our email client per se, so my question is more what can you tell me about what I can do to see where in the software/network chain the problem lies? The error we’re seeing is (IIRC) that the mailserver’s not responding to attempts on either 993/SSL or 143 without authenticating insecurely. I won’t have access to the machine again until late Sunday at the earliest.


#2

If I had to guess, the firewall flagged the IP, maybe for too many incorrect logins or something like that and it’s blocking the specific port. It does this to prevent someone from attempting to login to an email as much as they want to crack a password. If you send us an IP when you’re back in front of the computer we can check on that. Beyond that trying an alternative client would be one option, trying the same settings on another network (say phone hotspot for example) to rule out a firewall block would be another troubleshooting step to see where the disconnect is.


#3

Will check that when I have access to the machine again. It feels like a likely solution.

(Sending is OK, which I see I didn’t mention that in the original post.)


#4

Yeah sending uses SMTP over different ports than IMAP for receiving so that definitely indicates that a particular port is blocked for that computer which is often a firewall issue.


#5

We’re wading here into the land of “Networking Things I Feel Like I Should Know But Don’t”.

Easy enough for me to find my internal IPs, but we seem to be sharing a public IP because of being behind a shared router. Internals are 192.168.x.x, public seems to be 32.210.40.27, but I get that when I look for it from the problem laptop and a phone.

Is there some other thing I should be looking for?


#6

Logs are showing it was blocked a week ago but not currently. I did go ahead and whitelist it (the public IP is the only one the server reads no matter how many devices are on the same network). Any change?


#7

Yep – switching over to SSL seems to work now. Thanks for the whitelist, even if it wasn’t strictly necessary right now. We’re having other ISP issues, so it may be their glitches. I’ll keep an eye on things that I can, in any case.