WP Site not showing social icons


#1

Hi All,

I’m using the Dimension Theme as my landing page for my site (Thanks @cogdog, it’s so clean and pretty!) Usually when I build my social media menu, the icons for the social automatically appear, but not so right now.

Any ideas on what i might be doing wrong?

Tips very much appreciated!


#2

The social media icons are rendered via the FontAwesome for Menus 5 plugin; looking at the source of your page my guess is the plugin is missing or not activated (it should have come with the one click install).

Look under the Plugins in the Dashboard and see if this plugin is listed. If it is there, but not showing as active, click activate.

if it is not there, you need to download the Zip file for this plugin from
GitHub - cogdog/font-awesome-5-menus: WordPress plugin for adding Font Awesome Icons to Menus (use the green “Clone or download” button) and then install by uploading to WordPress in the Plugins area (Add New, then Upload).

The theme documentation tries to explain how to select the icons

Hope that gets your icons lit up.


#3

Fantastic! I got it to work, perfectly.

And now I know a bit more about this CSS thing I was finding daunting - thank you!


#4

Fantastic work! You figured it out perfectly. I added the site as an example for the theme


#5

I love being able to use the Font Awesome icons for stuff - I added a bunch into my Boxes, too, maybe overkill, but icons grab my attention. Thanks as always for your expert guidance!